hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Dimiduk <ndimi...@apache.org>
Subject Re: [VOTE] First release candidate for HBase 1.1.1 (RC0) is available
Date Thu, 25 Jun 2015 17:43:26 GMT
On Thu, Jun 25, 2015 at 4:23 AM, Jean-Marc Spaggiari <
jean-marc@spaggiari.org> wrote:

> Also, any idea why non of the tests pass on my side?
> I tried some of them individually and they passed:
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> Running org.apache.hadoop.hbase.master.TestClockSkewDetection
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.69 sec -
> in org.apache.hadoop.hbase.master.TestClockSkewDetection
> Results :
> Tests run: 1, Failures: 0, Errors: 0, Skipped: 0
> But it prevents me to run the entire test suite at once. I will give it few
> more tries today...

We have some flakey tests JM. Take a look at the build history for this
branch [0], branch-1, master... RM's have been filing tickets for the
biggest offenders, some of which have been picked up (thanks Mikhail,
Andrey, Stephen, Josh) but there's plenty more that haven't [1]. They get
pushed out to the next release.

I think dev's are out of practice running tests locally, and last I tried
them, our exclusive small/medium/large profiles are broken [2], which adds
even more barrier.

You can try to do as the Jenkins builds do, use the following when running
the full suite.

$ export MAVEN_OPTS="-Xmx6100M -XX:-UsePerfData"
$ ulimit -a
$ mvn clean
$ mvn -PrunAllTests -DreuseForks=false install
-Dsurefire.rerunFailingTestsCount=2 -Dit.test=noItTest

I've had a bit more luck locally with
bumping surefire.rerunFailingTestsCount up to 4, which means a test must
fail 5 times in order to sink the run. I've also considered tweaking the
level of parallelism configured in the poms, but haven't gotten there yet.

Your NoSuchMethod error on TestClockSkewDetection alarming. Do you have a
stack trace for that one? Do you know what method was missing?

[0]: https://builds.apache.org/job/HBase-1.1/
[2]: http://search-hadoop.com/m/YGbbq0V7iveAiC1

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message