hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Issues with HBase Regions in Transition
Date Wed, 02 Dec 2015 20:37:31 GMT
Do you mind pastebin snippet of region server log where the region stuck in
transition was hosted ?

This would give us some clue.

Cheers

On Wed, Dec 2, 2015 at 12:14 PM, Amanda Moran <amanda.moran@esgyn.com>
wrote:

> Hi there All-
>
> I apologize if this issue has been raised before... I have done ALOT of
> googling on this issues... and finally decided to just write here to the
> source :)
>
> Background:
>
> I work on the incubating Apache Trafodion project.
>
> I am currently using HBase 1.0 with Cloudera 5.4.5.
>
> I have tried many times to upgrade my cloudera cluster (to get the latest
> version of HBase) and have always failed due to my HBase master failing to
> come backup do to a Region suck in Transition. It is always the hbase:meta.
>
> In the past I just assumed that the upgrade feature just didn't actually
> work... and so even though frustrating... I just let it go.
>
> But now I have come across this issue again, in a slightly different way...
> and this makes me think it is an HBase problem.
>
> I am preparing for an upgrade, and because of this I decided to remove the
> "Trafodion".jar files that are located in the ../hbase/lib directory. I
> thought this might be the cause of not being able to upgrade, because I was
> leaving the trafodion files in this directory. I removed them, then did a
> deploy client config (since some configs were stale), and then did a
> restart. Now I have a region stuck in transition, even before the upgrade!
>
> Everything I have seen on the web, has not worked in the past. How do I get
> pass this issue? Do I have no choice but to do a full uninstall/reinstall
> and lose my data?
>
> Thanks all for any help!
>
>
> --
> Thanks,
>
> Amanda Moran
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message