hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Divya Gehlot <divya.htco...@gmail.com>
Subject [Query:]Table creation with column family in Phoenix
Date Fri, 11 Mar 2016 07:54:20 GMT
Hi,
I created a table in Phoenix with three column families  and Inserted the
values as shown below

Syntax :

> CREATE TABLE TESTCF (MYKEY VARCHAR NOT NULL PRIMARY KEY, CF1.COL1 VARCHAR,
> CF2.COL2 VARCHAR, CF3.COL3 VARCHAR)
> UPSERT INTO TESTCF (MYKEY,CF1.COL1,CF2.COL2,CF3.COL3)values
> ('Key2','CF1','CF2','CF3')
> UPSERT INTO TESTCF (MYKEY,CF1.COL1,CF2.COL2,CF3.COL3)values
> ('Key2','CF12','CF22','CF32')


 When I try to scan same table in Hbase
hbase(main):010:0> scan "TESTCF"

> ROW                   COLUMN+CELL
>  Key1                 column=CF1:COL1, timestamp=1457682385805, value=CF1
>  Key1                 column=CF1:_0, timestamp=1457682385805, value=
>  Key1                 column=CF2:COL2, timestamp=1457682385805, value=CF2
>  Key1                 column=CF3:COL3, timestamp=1457682385805, value=CF3
>  Key2                 column=CF1:COL1, timestamp=1457682426396, value=CF12
>  Key2                 column=CF1:_0, timestamp=1457682426396, value=
>  Key2                 column=CF2:COL2, timestamp=1457682426396, value=CF22
>  Key2                 column=CF3:COL3, timestamp=1457682426396, value=CF32
> 2 row(s) in 0.0260 seconds


My query is why I am getting CF1:_0 one extra column in each row with no
value.

Can any body explain me .
Would really appreciate the help.

Thanks,
Divya

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message