hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olaf Marzocchi <li...@marzocchi.net>
Subject "Quickstart" on OmniOS/illumos not working, java eats CPU
Date Sat, 12 Nov 2016 23:09:02 GMT
I tested HBase with OpenTSDB some time ago on OS X locally and the 
quickstart guide worked perfectly, merged with 
http://opentsdb.net/setup-hbase.html where necessary.

I tried yesterday to do the same on my OmniOS/illumos server and I 
encountered issues with HBase.

First of all I set "JAVA_HOME=/usr/java" in "conf/hbase-env.sh".

$ /usr/java/bin/java -version
openjdk version "1.7.0_101"
OpenJDK Runtime Environment (build 1.7.0_101-b00)
OpenJDK Server VM (build 24.101-b00, mixed mode)

I edited also "hbase-site.xml":


I then launched "bin/start-hbase.sh" and it quits apparently normally. A 
directory "/export/home/olaf/zookeeper" appeared, but no 

$ ls -l /export/home/olaf/
drwxrwxr-x   3 olaf     olaf           3 Nov 12 01:16 zookeeper

I also checked with prstat ("top") and I see that java is taking a full 
CPU. After some minutes it's still crunching something.
If I launch "./bin/hbase shell" it never gets to "hbase(main):001:0>".
At this point the only way is to kill -9 both java processes: the stop 
script doesn't work, it outputs dots forever.

I uploaded the two log files (.log and .out) to Pastebin:

I'm not sure where to begin with the debugging, since I did no 
customisation at all and I don't see any error logged.

I would be grateful for some help.


View raw message