hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ravi Hemnani <raviiihemn...@gmail.com>
Subject Re: Hbase hbck not working properly.
Date Tue, 09 Jan 2018 11:11:25 GMT
@Ted,

I can the following command,
'sudo -u hbase hbase hbck', now the rootdir being taken is
/tmp/hbase-hbase/hbase instead of /hbase and still reports error for
inconsistencies.

I apologize for the delay in reply/update.

On Fri, Jan 5, 2018 at 6:05 PM, Ravi Hemnani <raviiihemnani@gmail.com>
wrote:

> Hello all,
>
> I am in a fix right now where hbase hbck command is not running properly.
> It is picking up incorrect rootdir in order to search for regions info in
> hdfs and hence ultimately throwing 'No HDFS dir found' for all the regions
> in the cluster. It is searching in hdfs://nameservice1/tmp/hbase-{user
> running hbck command}/hbase as show below. Also along with this, none of
> the hbase hbck options are working, repair etc and exiting with status code
> 255. I am using hbase version 1.2. If anyone has faced something like this
> please help.
>
>
> """
>
>
>    1. 2018-01-05 11:28:44,051 INFO  [main] util.HBaseFsck: Loading region directories
from HDFS
>    2. ERROR: Version file does not exist in root dir hdfs://nameservice1/tmp/hbase-ravi/hbase
>    3.
>    4. 2018-01-05 11:28:44,162 INFO  [main] util.HBaseFsck: Loading region information
from HDFS
>
> """
>
> --
> Thank you and Regards,
>
> Ravi Hemnani.
>



-- 
Thank you and Regards,

Ravi Hemnani.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message