hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Thomsen <mikerthom...@gmail.com>
Subject Re: Custom filter appears to just hang
Date Sun, 15 Sep 2019 16:35:35 GMT
So that's just it, I don't see any errors at all on either the client side
or the server side. I'm running this against HBase 2.0.5, and I didn't see
anything showing up. Granted, I'm running server in local mode with just
"bin/hbase master start" and letting it manage ZK and create one
regionserver that way. As I said, I can read and write data just fine with
this setup until I throw the filter into the mix and then it mysteriously
hangs.

I've uploaded the whole project here, including the protobuf section:

https://github.com/MikeThomsen/hbase-test

Thanks,

Mike

On Fri, Sep 13, 2019 at 12:33 PM Esteban Gutierrez
<esteban@cloudera.com.invalid> wrote:

> Hi Mike,
>
> What errors do you see in the RegionServer or Client logs? Did you
> generated the Java class files for SimpleFilter from a proto file? The
> HBase Definitive Guide as a good example about how to write and deploy
> custom filters:
>
> https://www.oreilly.com/library/view/hbase-the-definitive/9781492024255/ch04.html
> see Example 4-23 and Example 4-24.
>
> But depending on the version of HBase you are using you might have to also
> take a look a the Protobuf section in the HBase Reference Guide to see
> where you should create the proto files and which jar should be used
> (shaded vs non-shaded) : https://hbase.apache.org/book.html#protobuf
>
> thanks,
> esteban.
>
> --
> Cloudera, Inc.
>
>
>
> On Fri, Sep 13, 2019 at 6:54 AM Mike Thomsen <mikerthomsen@gmail.com>
> wrote:
>
> > https://gist.github.com/MikeThomsen/ed3e742d13adeb63d45ceca7a09bf176
> >
> > I'm running this in standalone mode, with the jar file in the HBase lib
> > folder. When I run the client side of it, it gets to the print statement
> > that says Fetching.... and then just hangs. When I take the filter off
> the
> > Get, it pulls the row just fine. Can someone give me some help on why it
> > might be hanging?
> >
> > Thanks,
> >
> > Mike
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message