hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Dimiduk <ndimi...@apache.org>
Subject Re: [DISCUSS] Bump hadoop versions on up coming 2.3.0 and 3.0.0 releases
Date Fri, 13 Mar 2020 16:03:13 GMT
> For me, I prefer we just bump the hadoop version of 2.3.0 directly to
2.10.0, as 2.9.x is almost dead too.

For 2.3, I raised this question earlier on "[DISCUSS] Hadoop dependency
versions for 2.3" [0]. Our conclusion was "if it ain't broke, don't fix it."

Since we've had no previous communication of dropping support for 2.8, I
was planning to release 2.3.x as the last HBase release line with support
for Hadoop 2.8.x. I haven't investigated the changelog closely, nor am I
fully versed in the implications this might have in our interactions with
the HDFS APIs, so I don't have a technical argument for or against moving
forward this minor version dependency.

Lacking further information, I am -0 on changing this dependency. If we do
decide to bump the minimum Hadoop minor version for 2.3.x, I agree that we
should target 2.10.

Thank for bringing to light the new information, raising the question Duo,
and for your perspective, Wei-Chiu.

[0]:
https://lists.apache.org/thread.html/r2e4d47ebc49cb25a09e49dde1a652d5e952266547238b8e2d90685db%40%3Cdev.hbase.apache.org%3E



On Wed, Mar 11, 2020 at 5:57 PM Wei-Chiu Chuang <weichiu@apache.org> wrote:

> +1 I'd like to encourage the community to update and reduce the Hadoop 2.x
> presence as much as possible.
>
> There is not an official DISCUSS/VOTE thread to EOL Hadoop 2.9 yet, even
> though so far the feedback has been quite receptive to the idea.
>
> Hadoop 2.10 is meant to be a "bridge release" for those who are not ready
> to upgrade to Hadoop 3.x.
> Given that the main contributors (LinkedIn, Microsoft and Verizon Media)
> are on 2.10, bypassing 2.9 altogether, the Hadoop 2.9 is not going to get
> much attention. Looking at git history, branch-2.9's got just 13 commits.
>
>
>
> On Wed, Mar 11, 2020 at 5:35 PM 张铎(Duo Zhang) <palomino219@gmail.com>
> wrote:
>
> > Hadoop now has a wiki page to show the EOL releases lines
> >
> >
> >
> https://cwiki.apache.org/confluence/display/HADOOP/EOL+(End-of-life)+Release+Branches
> >
> >
> > 2.8.x is finally dead, so we'd better at least upgrade to 2.9.x in newer
> > release lines.
> >
> > And in this announcement
> >
> >
> >
> https://lists.apache.org/thread.html/r348f7bc93a522f05b7cce78a911854d128a6b1b8bd8124bad4d06ce6%40%3Cuser.hadoop.apache.org%3E
> >
> >
> > They even say you'd better upgrade to 2.10+.
> >
> > For me, I prefer we just bump the hadoop version of 2.3.0 directly to
> > 2.10.0, as 2.9.x is almost dead too. And since we still support hadoop
> > 2.9.x on 2.2.x release line, which is the current stable release line,
> > which should be fine for users.
> >
> > And for master branch, I suggest we just drop all the support for hadoop
> > 2.x and bump hadoop to 3.1.x directly.
> >
> > Thoughts? Thanks.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message