hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hive QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-21221) Make HS2 and LLAP consistent - Bring up LLAP WebUI in test mode if WebUI port is configured
Date Fri, 08 Feb 2019 04:20:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-21221?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16763289#comment-16763289
] 

Hive QA commented on HIVE-21221:
--------------------------------



Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12958000/HIVE-21221.1.patch

{color:red}ERROR:{color} -1 due to no test(s) being added or modified.

{color:green}SUCCESS:{color} +1 due to 15777 tests passed

Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/15992/testReport
Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/15992/console
Test logs: http://104.198.109.242/logs/PreCommit-HIVE-Build-15992/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.TestCheckPhase
Executing org.apache.hive.ptest.execution.PrepPhase
Executing org.apache.hive.ptest.execution.YetusPhase
Executing org.apache.hive.ptest.execution.ExecutionPhase
Executing org.apache.hive.ptest.execution.ReportingPhase
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12958000 - PreCommit-HIVE-Build

> Make HS2 and LLAP consistent - Bring up LLAP WebUI in test mode if WebUI port is configured
> -------------------------------------------------------------------------------------------
>
>                 Key: HIVE-21221
>                 URL: https://issues.apache.org/jira/browse/HIVE-21221
>             Project: Hive
>          Issue Type: Improvement
>          Components: llap
>            Reporter: Oliver Draese
>            Assignee: Oliver Draese
>            Priority: Trivial
>              Labels: llap
>         Attachments: HIVE-21221.1.patch, HIVE-21221.patch
>
>
> When HiveServer2 comes up, it skips the start of the WebUI if
> 1) hive.in.test is set to true
> AND
> 2) the WebUI port is not specified or default (hive.server2.webui.port)
>  
> Right now, on LLAP daemon start, it is only checked if hive is in test (condition 1)
above.
>  
> The LLAP Daemon start up code (to skip WebUI creation) should be consistent with HS2,
therefore if a port is specified (other than the default), the WebUI should also be started
in test mode.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message