hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-21666) Bad behavior with 'insert_only' property on non-transactional table
Date Wed, 12 Jun 2019 22:18:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-21666?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16862502#comment-16862502
] 

Todd Lipcon commented on HIVE-21666:
------------------------------------

That fix seems to have fixed it for CTAS, but does it fix it for other ways of ending up with
a table like this? eg if someone uses an external HMS client (eg Spark or Impala) to create
such a malformed table, or uses an ALTER TABLE command to set table properties, we should
also perform the same validation at read time, rather than giving this strange error.

> Bad behavior with 'insert_only' property on non-transactional table
> -------------------------------------------------------------------
>
>                 Key: HIVE-21666
>                 URL: https://issues.apache.org/jira/browse/HIVE-21666
>             Project: Hive
>          Issue Type: Bug
>          Components: Transactions
>            Reporter: Todd Lipcon
>            Assignee: Attila Magyar
>            Priority: Major
>
> I created a table with 'transactional_properties'='insert_only' but didn't specify 'transactional'='TRUE'.
I was able to insert into this table, but when I tried to query it, I got a NumberFormatException
since it appears the insert path used a non-transactional layout while the read path expected
one.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message