hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Work logged] (HIVE-21173) Upgrade Apache Thrift to 0.9.3-1
Date Thu, 18 Jul 2019 19:51:00 GMT

     [ https://issues.apache.org/jira/browse/HIVE-21173?focusedWorklogId=279279&page=com.atlassian.jira.plugin.system.issuetabpanels:worklog-tabpanel#worklog-279279
]

ASF GitHub Bot logged work on HIVE-21173:
-----------------------------------------

                Author: ASF GitHub Bot
            Created on: 18/Jul/19 19:50
            Start Date: 18/Jul/19 19:50
    Worklog Time Spent: 10m 
      Work Description: odraese commented on issue #730: HIVE-21173 Upgrade Apache Thrift
to 0.9.3-1
URL: https://github.com/apache/hive/pull/730#issuecomment-512960676
 
 
   We actually need to upgrade to Thrift 0.12 due to 4 CVE in the 0.9 line:
   https://www.cvedetails.com/product/38295/Apache-Thrift.html?vendor_id=45
   
   ...or are the CVE fixed in 0.9.3-1 (it seems a recent build from Feb)?
 
----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


Issue Time Tracking
-------------------

    Worklog Id:     (was: 279279)
    Time Spent: 0.5h  (was: 20m)

> Upgrade Apache Thrift to 0.9.3-1
> --------------------------------
>
>                 Key: HIVE-21173
>                 URL: https://issues.apache.org/jira/browse/HIVE-21173
>             Project: Hive
>          Issue Type: Bug
>          Components: Thrift API
>            Reporter: James E. King III
>            Assignee: David Lavati
>            Priority: Major
>              Labels: pull-request-available
>         Attachments: HIVE-21173.01.patch
>
>          Time Spent: 0.5h
>  Remaining Estimate: 0h
>
> The project currently depends on libthrift-0.9.3, however thrift released 0.12.0 on 2019-JAN-04.
This release includes a security fix for THRIFT-4506 (CVE-2018-1320). Updating thrift to the
latest version will remove that vulnerability.
> Also note the Apache Thrift project does not publish "libfb303" any longer. fb303 is
contributed code (in '/contrib') and it has not been maintained.
>  
> Ps.: 0.9.3.1 also addresses the CVE, see THRIFT-4506



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message