hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manoj Narayanan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-21713) Explain consistency Task/Operator
Date Sat, 13 Jul 2019 17:39:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-21713?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16884425#comment-16884425
] 

Manoj Narayanan commented on HIVE-21713:
----------------------------------------

Ok. I think we should 
* Have Operator or Task at the end based on the type.
* Operator/Task Class name where words are separated by space.  (That's how currently most
of Operators are named)
* No changes if already above rule is met. (for e.g.:Merge Join Operator)


> Explain consistency Task/Operator
> ---------------------------------
>
>                 Key: HIVE-21713
>                 URL: https://issues.apache.org/jira/browse/HIVE-21713
>             Project: Hive
>          Issue Type: Improvement
>            Reporter: Zoltan Haindrich
>            Assignee: Manoj Narayanan
>            Priority: Major
>
> there seems to be some inconsistency what gets printed in the explain;
> for example "MoveTask" is shown as "Move Operator" in the explain
> Becase Tasks and Operators are basically different things - this should be corrected
as it may cause confusion



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message