hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mustafa Iman (Jira)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-20359) Update protobuf version in pom.xml
Date Fri, 05 Jun 2020 21:25:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-20359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17127097#comment-17127097
] 

Mustafa Iman commented on HIVE-20359:
-------------------------------------

[~dlavati] I think we can we leave hbase-handler at old version and upgrade the rest of the
system.

Protobuf2 Generated classes are not guaranteed to be compatible with protobuf3 runtime ([https://groups.google.com/forum/#!topic/protobuf/AwJlDT8ZWjQ)|https://groups.google.com/forum/#!topic/protobuf/AwJlDT8ZWjQ).] So
we need to re-compile the proto files with protobuf3. Luckily wire format of protobuf 2 and
3 are compatible. Only thing is we need to relocate protobuf3 dependency in hive to prevent
classpath issues.

> Update protobuf version in pom.xml
> ----------------------------------
>
>                 Key: HIVE-20359
>                 URL: https://issues.apache.org/jira/browse/HIVE-20359
>             Project: Hive
>          Issue Type: Improvement
>          Components: Hive
>    Affects Versions: 3.1.0
>         Environment: ARM64 Server machines with CentOS/Debian OS.
>            Reporter: Naresh Bhat
>            Priority: Major
>              Labels: pull-request-available
>             Fix For: 3.1.0, 4.0.0
>
>         Attachments: HIVE-20359.01.branch-3.1.patch, HIVE-20359.01.branch-3.1.patch,
HIVE-20359.01.patch, HIVE-20359.01.patch, HIVE-20359.01.patch
>
>          Time Spent: 0.5h
>  Remaining Estimate: 0h
>
> The following protoc version's used in hive is very old i.e. 2.5.0 [https://repo.maven.apache.org/maven2/com/google/protobuf/protoc/]
.  The v2.5.0 does not have aarch64 support. But the AArch64 support started from v3.5.0
on-words in google's protobuf project release.  The hive release version branch v3/3.0/3.1/master
branch build fails on AArch64 because of old protoc version 2.5.0, in which there is no AArch64
support/exe available.
> After I replaced to latest available protoc version 3.6.1 the hive master branch pom.xml
files, The hive compiled without any issues on ARM64 machine.  This Jira ticket is used to
propose a patch on Hive mailing list [https://git.linaro.org/people/naresh.bhat/apache/hive.git/] 
to update pom.xml files protobuf version.  I will also cherry-pick patches for other branches
v3/3.0/3.1, and create a pull request.
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message