hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "L. C. Hsieh (Jira)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-23980) Shade guava from existing Hive versions
Date Thu, 06 Aug 2020 16:11:00 GMT

     [ https://issues.apache.org/jira/browse/HIVE-23980?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

L. C. Hsieh updated HIVE-23980:
-------------------------------
    Attachment: HIVE-23980.01.branch-2.3.patch
        Status: Patch Available  (was: Open)

> Shade guava from existing Hive versions
> ---------------------------------------
>
>                 Key: HIVE-23980
>                 URL: https://issues.apache.org/jira/browse/HIVE-23980
>             Project: Hive
>          Issue Type: Bug
>    Affects Versions: 2.3.7
>            Reporter: L. C. Hsieh
>            Assignee: L. C. Hsieh
>            Priority: Major
>              Labels: pull-request-available
>         Attachments: HIVE-23980.01.branch-2.3.patch
>
>          Time Spent: 40m
>  Remaining Estimate: 0h
>
> I'm trying to upgrade Guava version in Spark. The JIRA ticket is SPARK-32502.
> Running test hits an error:
> {code}
> sbt.ForkMain$ForkError: sbt.ForkMain$ForkError: java.lang.IllegalAccessError: tried to
access method com.google.common.collect.Iterators.emptyIterator()Lcom/google/common/collect/UnmodifiableIterator;
from class org.apache.hadoop.hive.ql.exec.FetchOperator
> 	at org.apache.hadoop.hive.ql.exec.FetchOperator.<init>(FetchOperator.java:108)
> 	at org.apache.hadoop.hive.ql.exec.FetchTask.initialize(FetchTask.java:87)
> 	at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:541)
> 	at org.apache.hadoop.hive.ql.Driver.compileInternal(Driver.java:1317)
> 	at org.apache.hadoop.hive.ql.Driver.runInternal(Driver.java:1457)
> 	at org.apache.hadoop.hive.ql.Driver.run(Driver.java:1237)
> 	at org.apache.hadoop.hive.ql.Driver.run(Driver.java:1227)
> {code}
> I know that hive-exec doesn't shade Guava until HIVE-22126 but that work targets 4.0.0.
I'm wondering if there is a solution for current Hive versions, e.g. Hive 2.3.7? Any ideas?
> Thanks.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message