httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject t/modules/expires fixup
Date Tue, 07 Aug 2001 07:25:41 GMT
I've attached a new t/modules/expires.t (and a patch), since it pretty
much rewrites the test so you want to see the new code and not the patch.
I didn't change the flow, but perlify the code and added all the required
checkings, since the test won't work at all for me.

Remember that you have:
use warnings FATAL => 'all';

which means that any emitted warning immediately aborts the test.

I've also changed the indent, again please tell me if I should stop that.

Also please note that you can leave all the debug notes in the test, and
they won't affect the test. But if you want to see the debug notes, just
add -v, e.g.:

% perl t/TEST httpd /home/stas/httpd-2.0/bin/httpd -run -v  t/modules/expires.t

still after rewriting the test, half of the sub-tests fail, because the
'Expires' header is not there.  I did check that I have
in ./t/conf/extra.conf.in:

##
<IfModule mod_expires.c>
<Directory @SERVERROOT@/htdocs/modules/expires>
ExpiresActive On
ExpiresDefault "modification plus 10 years 6 months 2 weeks 3 days 12
hours 30 $ExpiresByType text/plain M60
ExpiresByType image/gif A120
ExpiresByType image/jpeg A86400
</Directory>
</IfModule>


_____________________________________________________________________
Stas Bekman              JAm_pH     --   Just Another mod_perl Hacker
http://stason.org/       mod_perl Guide  http://perl.apache.org/guide
mailto:stas@stason.org   http://apachetoday.com http://eXtropia.com/
http://singlesheaven.com http://perl.apache.org http://perlmonth.com/


Mime
View raw message