httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: perl-framework server startup
Date Thu, 27 Dec 2001 17:25:21 GMT
Rodent of Unusual Size wrote:

> If I get this:
> 
> the server is down, giving up after 601 secs
> !!! : failed to start server! (please examine t/logs/error_log)


601 secs? shouldn't it be 60?


> the exit status of t/TEST appears to be *successful*.  In
> other words, I can't make a script decision based on whether
> the tests were able to run or not.  I tried looking at
> fixing this, but the codepath seems so convoluted that it's
> entirely unclear to me whether some subs should be 'return 0'
> or 'return 1'.. :-(


does this solve the problem?

Index: Apache-Test/lib/Apache/TestRun.pm
===================================================================
RCS file: 
/home/cvs/httpd-test/perl-framework/Apache-Test/lib/Apache/TestRun.pm,v
retrieving revision 1.76
diff -u -r1.76 TestRun.pm
--- Apache-Test/lib/Apache/TestRun.pm	2001/12/22 02:28:27	1.76
+++ Apache-Test/lib/Apache/TestRun.pm	2001/12/27 17:23:47
@@ -561,7 +561,7 @@

      $self->die_on_invalid_args;

-    $self->start;
+    exit 1 unless $self->start;

      $self->run_tests;


BTW, I've sent a patch which aborts waiting if the server has failed to 
start right away. I guess Doug is on vacation to +1 it, should be in 
probably soon.



_____________________________________________________________________
Stas Bekman             JAm_pH      --   Just Another mod_perl Hacker
http://stason.org/      mod_perl Guide   http://perl.apache.org/guide
mailto:stas@stason.org  http://ticketmaster.com http://apacheweek.com
http://singlesheaven.com http://perl.apache.org http://perlmonth.com/


Mime
View raw message