httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William McKee <will...@knowmad.com>
Subject Re: Trace level defaults to 'debug'
Date Wed, 21 Jan 2004 21:31:50 GMT
On Wed, Jan 21, 2004 at 12:35:07PM -0800, Stas Bekman wrote:
> William McKee wrote:
> >The testing documentation at perl.apache.org says that the current trace
> >level defaults to info. However, my system is outputting debug messages
> >to the t/logs/error_log file. Is this the correct behavior in which case
> >the docs are wrong? Or have I somehow configured my system to default to
> >debug mode?
> 
> What are the 'debug' messages you are talking about?

The [debug] messages in the t/logs/error_log. In particular the ones
that look like the following:

[Wed Jan 21 15:58:25 2004] [debug] mod_cvs.c(217): CVSCheck is off here: /index.html


> The Apache LogLevel is set to 'debug':
> 
> % grep Level t/conf/httpd.conf
> LogLevel    debug

That's the one I needed to set.


> The Apache-Test tracing mechanism is set to 'info'. so:
> 
> use Apache::TestTrace;
> info "doing foo";  # will be logged
> debug "doing bar"; # won't be logged

That makes sense now. I'm still getting the client and server stuff
mixed up :).


> Refer to the Apache::TestTrace manpage for more information.

Thanks.


> Please suggest a clarification to the docs now that you know all the 
> answers to this issue, William ;)

Attached :).


Thanks,
William

-- 
Knowmad Services Inc.
http://www.knowmad.com

Mime
View raw message