httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <>
Subject Re: Failures in with A::T 1.09
Date Thu, 11 Mar 2004 22:19:46 GMT
William McKee wrote:
> On Thu, Mar 11, 2004 at 10:32:08AM -0800, Stas Bekman wrote:
>>rgs suggested to try B::Concise, which show you what the opcode tree looks 
>>like. Try the patch below. Does it still fail as before? (all I did is just 
>>commenting out some redundant code, which will not prevent us from running. 
>>If it does fail the same way, uncomment the line:
>> #B::Concise::compile(__PACKAGE__."::set_ulimit_via_sh")->();
>>% t/TEST -start
>>and post the output. Thanks.
> I had troubles applying the patch (I was using `patch -u -p0 <`),
> so just manually made the changes. Not much to report as the server
> started up with no errors. I went back and uncommented the lines in
> set_ulimit_via_sh and tried starting the server. It starts up fine.

You mean the current cvs without any patches starts just fine. It's only when 
you run tests you get this problem?

> I figured that my system was about to make a liar out of me but when I
> ran the tests, I got the error. Furthermore, if I commented ou the lines
> in set_ulimit_via_sh as per the patch you sent, I continue to get the
> error.
> So, I uncommented the B::Concise line and here's the output:

Before you uncommented B::Conside, was it failing?

> I hope this helps someone understand what's happening on my end. I'm
> afraid it's pretty foreign to me since I have not studied the Perl
> internals. Let me know if I can provide any further testing.

It's still pretty foreign to me too ;)

Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->

View raw message