httpd-test-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <>
Subject Re: httpd test (perl-framework)
Date Thu, 15 Apr 2004 18:47:27 GMT
[dropping the irrelevant CC address]

Abhishek Khandelwal wrote:
> I am getting the following error when I run the perl-test framework.
> I get this error when I run the test twice, one after another.
> The first time, it goes thru properly and prints the summary of the
> results.
> But When I run for the second time, I get this error. I am using same
> extra.conf in both the runs, but in second run, it fails. 
> Anyone has any idea about what might be the reason for the error.
> This is the error:::

> waiting 60 seconds for server to start: .Syntax error on line 16 of
> /usr/local/nightly/cvs-root/oss/core/webserver/httpd/test/perl-framework/t/conf/extra.conf:
> Invalid command 'Order', perhaps mis-spelled or defined by a module not included in the
server configuration

Abhishek, the directive Order needs mod_access to be loaded. Is your server 
built with mod_access built in or as a shared object?

What do you mean by running the test twice? Like so:

make test
make test

In which case, save away t/conf after the first 'make test' and then when the 
second time it fails compare the two directories (diff -ru t/conf.old t/conf). 
Do you see any difference?

Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->

View raw message