httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Hawkes <ahaw...@unicon.net>
Subject Re: Apache can't see the .so that is in path
Date Wed, 23 Jan 2002 18:29:33 GMT
The important thing here is not $PATH, but $LD_LIBRARY_PATH (since
libqtintf.so is a shared object).

I believe you need to use the SetEnv directive in your httpd.conf so that
your CGI script has it right.

SetEnv LD_LIBRARY_PATH /wherever/your/shared/objects/are

Typically .so's go in directories called 'lib', not bin.

-Andy


On Wed, 23 Jan 2002 19:27:17 +0000
Csillag Zsolt <starsoft@interware.hu> wrote:

> Hi,
> 
> 
> 
> My environment:
> Suse Linux 7.1, Kernel: 2.2.18 (i686)
> Kylix 1
> Apache/1.3.17
> 
> The problem:
> - If me make a little cgi that runs perfectly ( the cgi is in the
cgi-bin 
> directory)
> - If I modify the cgi in Kylix(our programming language) and put up a
new 
> component
> (DOA) to access Oracle database, then it stops working
> 
> - In the browser the error message is:
> Not Found
> The requested URL /cgi-bin/doacgi.cgi was not found on this server.
> Apache/1.3.17 Server at localhost Port 80
> 
> - However in the apache log file I can read:
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler(): Entry
> point... [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler():
> r->the_request =
> [GET /cgi-bin/doacgi.cgi HTTP/1.1]
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler(): r->protocol
> =
> [HTTP/1.1]
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler(): r->proto_num
> =
> 1001
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler(): r->filename
> =
> [/usr/local/httpd/cgi-bin/doacgi.cgi]
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler(): r->uri
> =
> [/cgi-bin/doacgi.cgi]
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler():
> r->content_type =
> [(null)]
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler(): r->handler
> =
> [cgi-script]
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip: This item was NOT
> FOUND in
> any mod_gzip httpd item record.
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip: This item will NOT be
> processed.
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip: action_flag =
> MOD_GZIP_IMAP_DECLINED1
> [Sun Jan 20 17:13:46 2002] [debug] (0): mod_gzip_handler(): Exit:
> return( rc
> = -1 = DECLINED )
> [Sun Jan 20 17:13:46 2002] [error] [client 127.0.0.1] script not found
> or
> unable to stat: /usr/local/httpd/cgi-bin/doacgi.cgi
> cgidoa.cgi: error while loading shared libraries: libqtintf.so: cannot
> open
> shared object file: No such file or directory
> [Sun Jan 20 14:35:56 2002] [error] [client 127.0.0.1] Premature end of
> script
> headers: /usr/local/httpd/cgi-bin/cgidoa.cgi
> 
> 
> So I think the libqtintf.so file is the problem.
> However this file is in user's home/kylix/bin directory and it is in the
> path. And what is more it has the permissions that anybody could make
> anything to it.
> 
> The cgi is in the cgi-bin directory of the Apache server.
> I have tried to copy and/or make soft links of  i in different
> directories used by Apache with no result.
> I' ve read about 100 pages from apache.org and everything seems good in
> the httpd.conf.
> 
> 
> It seems to me that Apache can't se anything that is in the Path.
> 
> 
> Thank you in advance
> 
> 
> 
> 
> Zsolt Csillag,
> Hungary
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message