httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From -bill- <b...@TechServSys.com>
Subject Re: VHosts and SSL
Date Tue, 15 Jan 2002 13:27:30 GMT
Mark Constable wrote:
> 
> On Tue, 15 Jan 2002 08:11, Robert L. Harris wrote:
> 
> > page.  I don't get the page that is displayed on the http port.  I tried
> > putting the "SSLEngine on" directive in the VirtualHost block and the
> > only change is it asks for my password on the cert.
> >
> > It's got to be something stupid I know.  Care to beat me upside the
> > head with a blunt object?
> 
> Well you asked for it :)
> 
> This is perfectly correct behaviour as NameVirtualHosts
> will not work with SSL. The necessary "Host" header is
> not available to apache via an https URL so it cannot
> figure out what vhost you are trying to go to, so defaults
> to the first configured vhost on the same IP.
> 
> You can only get what you are after by supplying different
> IPs for each vhost. I know, it's a bummer.
> 
> --markc
> 
you can have 1 SSL host (the default) and any number of non-ssl vhosts can you
not ?

-- 
- bill -

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message