httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CDitty <m...@redhotsweeps.com>
Subject Building apache from source / LoadModules problem
Date Fri, 18 Jan 2002 02:00:58 GMT
Hello all.  I am trying to compile apache 1.3.22 to use .so modules but I 
am having problems.  I am also compiling php into it too.

When I use the AddModule and LoadModule commands and run apachectl 
configtest, I get the following error.
Syntax error on line 206 of /usr/local/apache/conf/httpd.conf:
Invalid command 'LoadModule', perhaps mis-spelled or defined by a module 
not included in the server configuration

I also ran a httpd -l and the module I am adding is not included.  I have 
searched the archives and didn't really find anything helpful.

Below are the commands that I am running to compile the sources.

./configure --prefix=/usr/local/apache --enable-module=most --enable-shared=max
make
cd ../php-4.1.1
./configure --with-mysql --with-apache=../apache_1.3.22 --enable-track-vars
make
make install
cd ../apache_1.3.22
./configure --activate-module=src/modules/php4/libphp4.a
make
make install

What am I missing?

Thanks

CDitty


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message