httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hasanuddin Tamir <...@trabas.com>
Subject Re: Newbie needs help setting up SSI
Date Sun, 27 Jan 2002 06:26:32 GMT
On Sat, 26 Jan 2002, Scott Andersen <scott.andersen@gmx.net> wrote,

> Hello,
> I'm new to Apache and am hoping someone can help me outÂ…. I've installed
> the latest version of Apache for Win32 on Windows 2000 Professional
> locally for both testing and learning, in D:/Apache Group/Apache. I've
> followed the directions to enable SSI and I can't get it to work. (at
> least I think I've followed the instructions by uncommenting AddHandler
> cgi-script .cgi, AddType text/html .shtml
> and  AddHandler server-parsed .shtml. Like I said, I'm new to Apache and
> in the process of learning it on Windows 2000.  Any help would be
> greatly appreciated.

Hi,

Actually, the cgi-script part has nothing to do with SSI, it has another
purpose.

Anyway, you don't provide enough information about what "you can't get it
work".  But you can try it by inspect one or more of these questions:

1. Do you have your html filenames end with .shtml?
2. Do you have Includes entry in Options directive in
   <Directory /path/to/ssi/directory>...</Directory> directive?
3. Do you have Options entry in AllowOverride directive so you
   can put Options Includes in htaccess file?
4. Do you have index.shtml entry in DirectoryIndex directive?
5. Do you use SSI syntax in html files correctly?
6. Do your check your error log file?

Please be more descrictive.


hth
-- 
san->http(www.trabas.com)


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message