httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Andersson" <>
Subject mod_perl: Cannot load ...
Date Fri, 14 Jun 2002 06:27:17 GMT
Hello all,

I've just managed to get hold of mod_perl for Apache 2, and tried to get it
working. The problem is that the server won't start anymore, but just spits
out this message:

Syntax error on line 172 of G:/usr/local/apache2/conf/httpd.conf:
Cannot load G:/usr/local/apache2/modules/ into server: The
specified module could not be found.

Now, I can asure you that it really is there. I tried to give another module
the exact name of mod_perl, and Apache then, as expected, tells me that it
can't locate the API module structure etc...

I have Apache 2.0.36 on Windows XP, and not much extra than PHP 4.2.1.
Besides this I have ActiveState's Perl
I installed mod_perl by following the instructions on:
That is, I installed mod_perl by using ppm, adding this line:
LoadModule perl_module modules/ httpd.conf, and restarted. But no; it's something it doesn't like.

Somewhat confusing is that, on the page mentioned above, they tell us:
"For the adventuresome who want a taste of things to come, a
mod_perl-2.0/Apache-2.0 binary distribution based on cvs sources is
available from See the
accompanying Apache2.readme file in this directory for more details. Be
aware though that, being a pre-release version, bugs are most likely
As some suggested one should use the module included in this release I did
so, but then Apache says that the module isn't compatible with this version
of Apache.

If anyone knows what is going on here, or can point to what I do wrong,
please let me know!

Robert Andersson

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message