httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Levine <>
Subject Apache+PHP+Java
Date Fri, 14 Jun 2002 22:33:03 GMT
Hi - I'm having some problems getting Java support in PHP under Apache
on FreeBSD 4.6-RELEASE, and was wondering if anyone has any ideas.

Here's what I've done so far:

I installed the FreeBSD JDK13 port and then re-compiled PHP with Java
support.  When I tried running a script with Java, Apache returned:
Fatal error: Unable to create Java Virtual Machine in
/usr/home/research/htdocs/java.php on line 3

and put this in the error log:
Cannot open "/usr/local/jdk1.3.1/jre/lib/i386/native_threads/"

Based on a few Google searches, I re-compiled JDK13 WITH_NATIVE_THREADS

and Apache started logging this error message:
/usr/local/jdk1.3.1/jre/lib/i386/native_threads/ Undefined
symbol "pthread_mutex_init"

so, based on more Google searches I tried re-compiling Apache with this
in my environment:

I got an error in the make, so I tried:
-pthread and -lc_r

and that seemed to work.

Now Apache is logging this in the error log:
Can't load library "/usr/local/jdk1.3.1/jre/lib/i386/",
because Shared object "" not found
# locate

I have this in my php.ini file:
java.class.path =
java.home = /usr/local/jdk1.3.1
java.library = /usr/local/jdk1.3.1/jre/lib/i386/classic/
java.library.path =

and I've tried adding this to my apachectl script:
export LD_LIBRARY_PATH=/usr/local/jdk1.3.1/jre/lib/i386

Any other suggestions?  Is there some other way for me to tell Apache
where to find

Thanks in advance,
Josh Levine

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message