httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sam" <sim...@adria-web.com>
Subject Re: [users@httpd] Re: Webalizer won't give country info
Date Wed, 21 May 2003 13:47:35 GMT
This is the tip I found online that helped me when I had those problems.

"If you really need built in DNS support, it's really quite simple, however
different distributions place the required headers and libraries in
different places, so the configure script fails to find them. In a nutshell,
you need the Berkeley DB libary, and it needs to be configured with V1.85
API support. Most Linux distributions already have this library present. If
you get errors about not finding the proper header file (db_185.h), locate
it on your system and create a symbolic link to it in the /usr/include
directory. You will also need to specify the correct library to use for the
header. This may mean that you need to first run the configure script, then
if the compile fails due to unresolved references, edit the Makefile and
change the -ldb (or -ldb1) reference to the correct library, such
as -ldb-3.2 for RedHat, or just -ldb for Slackware 8. Each distribution
either names the library something different, or puts it in a different
location, so you will have to play around with it on your distro to get it
to work. If the library is in some non-standard location, you may also need
to specify it's path using the --with-dblib=... switch when you run the
configure script. Bottom line is, if you don't really need it (and most
people don't), just compile without DNS support and let your web server do
the name lookups for you."

"To compile under RH 7.x or 8.x using DNS resolver, you must use this
command line:
./configure --enable-dns --with-db=/usr/include/db1
You must have the db1 and the db1-devel RPMs installed in order to do this."

Hope this helps
Sam

----- Original Message -----
From: "GMane" <robert_schmidli@hotmail.com>
To: <users@httpd.apache.org>
Sent: Wednesday, May 21, 2003 3:05 PM
Subject: [users@httpd] Re: Webalizer won't give country info


>
> "Sam" <simona@adria-web.com> wrote in message
> news:004a01c31f82$ae1f4400$0d01a8c0@adriaweb...
> > > I have installed webalizer on my Mandrake 9.0 webserver.  In the past
> > > webalizer has been able to give me information about usage by country.
> > Now,
> > > however, all I get is "100.00% Country Unresolved/Unknown".
> > >
> > > Is there any way to remedy this or is it not possible to get more
> > > information?
>
> > I am not sure, but I had a similar problem and I had to recompile
> webalizer
> > with --enable-dns option. Take a look at DNS.README.
> > Sam
> >
>
> Thanks.  I think I'll try this option.  When I try to run ./configure with
> the DNS option enabled I get:
>
>     checking whether char is unsigned... (cached) no
>     checking for dbopen... (cached) no
>     checking for library containing dbopen... (cached) no
>     configure: warning: You must have a V1.85 compatable DB library!
>     configure: warning: DNS lookup code will be disabled...
>
> I have tried installing libdb but still get the same message.  What am I
> missing?  I'm using Mandrake 9.0
>
> Robert.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message