httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean O'Neill <s...@seanoneill.info>
Subject [users@httpd] Question on Digest Authentication and a very ANNOYING error message
Date Sun, 11 May 2003 00:29:13 GMT
I'm using Apache Apache/2.0.45 on FreeBSD 4.8. I have a cgi-bin script setup in httpd.conf
so that you must authenticate before using it (its the user_manage perl stuff from Lincoln
D. Stein).  I have it setup to use Digest Authentication.  But I've hit a snag with it. If
I access the script as: /cgi-bin/user_manage">http://<server>/cgi-bin/user_manage
It works fine.  Well, sorta.  The user_manage script as the ability to manage multiple Digest
realms with each realm having its own password/groups files.  REALLY a nice feature.  Without
specifying a realm to edit, user_manage simply grabs the first defined realm in its configuration.
 With the above URL reference, I get prompted for a user/password in the first realm found
in user_manage's configuration and it works fine. Now the problem, if I try to access it like
this: /cgi-bin/user_manage?realm=SubversionRepos">http://<server>/cgi-bin/user_manage?realm=SubversionRepos
I get prompted for the login/password followed by an error saying the page cannot be found.
 The above is how the script should be addressed so that you can modify various realms as
necessary.  Using the above, I get the following error in my Apache error file: [Sat May 10
19:25:30 2003] [error] [client 192.168.2.100] Digest: uri mismatch - </cgi-bin/user_manage>
does not match request-uri </cgi-bin/user_manage?realm=SubversionRepos>
Does anyone know how I get get around this VERY annoying error ?

--
........................................................
......... ..- -. .. -..- .-. ..- .-.. . ... ............
.-- .. -. -... .-.. --- .-- ... -.. .-. --- --- .-.. ...

Sean O'Neill
Mime
View raw message