httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean O'Neill <s...@seanoneill.info>
Subject [users@httpd] RESOLVED Re: Question on Digest Authentication and a very ANNOYING error message
Date Thu, 15 May 2003 18:35:16 GMT
At 09:54 PM 5/12/2003 -0500, Sean O'Neill wrote:
>
>[Sat May 10 19:25:30 2003] [error] [client 192.168.2.100] Digest: uri 
>mismatch - </cgi-bin/user_manage> does not match request-uri 
></cgi-bin/user_manage?realm=SubversionRepos>
>Does anyone know how I get get around this VERY annoying error ?

This is apparently a problem with the IE 6 browser.  I don't know why I 
didn't at the time I posted this but I just tried using Netscape 7, Opera 
7.11, and Konqueror - they all work just dandy.

The issue appears to be when IE6 gets told that Digest authentication is 
required the response packet it sends back which contains all the 
authentication info isn't right.  I'm going to say this wrong but the 
portion of the response the begins with "Authentication:" has a "uri=" 
field in it.

The uri field in the Opera (and I assume Netscape and Konqueror) response 
packet looks like this:

uri=/cgi-bin/user_manage?realm=SubversionRepos

while this same field in the IE 6 response packet looks like this:

uri=/cgi-bin/user_manage

Based on this, the error message coming from Apache makes sense now when 
using IE.


--
Sean O'Neill 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message