httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Crawford <rcrawf...@unexmail.ucdavis.edu>
Subject [users@httpd] Perl/Apache Problems
Date Fri, 30 May 2003 23:41:53 GMT
I am running Apache 2.0.44 on Solaris 9, with mod_perl and Perl 5.6.0.  No 
matter how I tweak the server, I am still getting the source code when I 
browse to the website.

The Perl script starts with

#!/usr/bin/perl

I have confirmed that Perl is there (actually, it's a symlink to another 
directory where Perl 5-6.0 lives; and I've tried changing the #! line to 
point at that directory, to no avail).

The script has been chmod'ed to 755, so it should be executable.  I've 
tried running it from the command line (with "$ /usr/bin/perl tocGet.pl") 
and there were no errors.

In httpd.conf, I have the following lines:

AddHandler cgi-script pl cgi

<Directory "/var/www/html/home/stuff/*/">
     SetHandler cgi-script
     AllowOverride None
     Options ExecCGI FollowSymLinks
     Order allow,deny
     Allow from all
</Directory>

I've checked the documentation on the Apache website and found nothing that 
I should be doing in addition to this.

I am running Macromedia JRun, a JSP interpreter, on this same server, but I 
don't think that's the problem.  I've Googled extensively and found no 
documentation of any problems with Perl and JRun on the same server.  I'm 
convinced that this is an Apache configuration problem, probably compounded 
by id10t errors. ;-)

Any suggestions or advice would be more than welcome.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message