httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marko Leer <ma...@half2.nl>
Subject [users@httpd] AddTypes in <Directory>
Date Fri, 16 May 2003 06:57:13 GMT
Hello all,

I'm running Apache 1.3.27 and I'm wondering why my configuration
doesn't work if I add an addType within a <Directory> within a
<Virtualhost> like this:

<VirtualHost 123.123.123.123>
[some more stuff here]
           <Directory /home/users/foo>
           AddType application/x-httpd-php .php
           AddType application/x-httpd-php .html
           AddType application/x-httpd-php .dgif
           AddType application/x-httpd-php .img
           AddType application/x-httpd-php .htm
           AddType application/x-httpd-php .php
           </Directory>
</Virtualhost>

My files do get parsed with the AddType application/x-httpd-php .php
directive any other place in the conf, but on this server I need to
set which virtuals are able to use PHP.

I'm a bit lost here since I couldn't find any documents concerning
this set-up; I know this construction was in the httpd.conf of the
server of my former employer and actually worked...

Any help appreciated.

Cheers

Marko.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message