httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy Henderson" <r_hender...@rebexitservices.co.uk>
Subject [users@httpd] Using VirtualHost on local machine only works with active internet connection
Date Sat, 10 May 2003 02:02:54 GMT
Hi,

I think this is actually more of a Windows or Internet Explorer
configuration problem than an Apache problem, but I am sure that others have
encountered and resolved this ...

I am running Apache 1.3 on my local machine which is running Windows/XP Pro
+ SP1. I am using IE6 as my browser.

If I do NOT configure any VirtualHosts, then I can serve files from my local
disk htdocs folder by using 127.0.0.1 as the URL.

However, if I configure some Virtualhosts, then these will only serve off my
local disk if I also have an active internet connection.

If I do not have an active internet connection, then IE prompts me to
connect. If I connect, then it will serve the local file. If I do not
connect, then it fails.

I have the virtualhosts in my HOSTS file and they are all mapped to
127.0.0.1 - if I ping by hostname they resolve to 127.0.0.1 and echo the
pings.

To me, the problem really seems to be how to get IE to check the hosts file
and discover that the virtualhosts are actually on 127.0.0.1 before trying
its internet connection ...

Any assistance would be most appreciated.

Roy




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message