httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael A. Lewis" <>
Subject [users@httpd] Segmentation errors
Date Thu, 22 Jan 2004 23:41:38 GMT
I have a site that has been running for a month at least with no problems. Nothing on the site
has changed in the last several days. I get a call this afternoon from one of my users that
they can't see some of the pages. It turns out that any page that attempts (via a PHP script)
to connect to a SQL SERVER server gets the error. I am running Red Hat 9.0, Apache 2.0.48,
PHP 4.3.4 and Freetds 0.61. I have a script that consists of a mssql.connect statement only
and it fails only when server from Apache. I can run the same script from the command line
ala "php bad.php". I observe the same behavior using PERL. I run a perl command line script
and it runs fine. I run he same script via apache and it doesn't work. Apache serves up all
other pages (including connections to my MYSQL server).
What I've done:
recompiled and installed php
recompiled and installed apache
recompiled and installed freetds
installed and compiled apache 2.0.47
went back to 2.0.48
tried kernel 2.4.6
returned to kernel 2.4.20
pulled what's left of my hair out
There is 147 gig of free disk space and 2 gig of memory on the system. Currently I am the
only user while I have trying to fix it.
Help! Any ideas or thoughts will save my bacon.
View raw message