httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wong, Sherman" <>
Subject [users@httpd] sybase php and apache
Date Mon, 26 Jan 2004 11:33:16 GMT
Hi guys,

I have tried quite a lot of combinations already. But sybase, php and apache 
seemed not a very good mixture that I can't even get thru' the make process.

Here is the story:
I have sybase-11.9.2, apache-1.3.29 on Redhat9.0
I have tried from php-4.3.4 and backward. Not Until I tried php-4.0.6 and the 
below parameters, I could not get the PHP successfully compiled.

configure --with-sybase=/opt/sybase-11.9.2 \
 --with-apache=/usr/local/src/apache_1.3.29 \
 --enable-track-vars \
 --disable-ctype \
 --disable-cli \

without the 3 disable statements, I get

ext/mysql/libmysql/my_tempnam.o(.text+0x40): In function `my_tempnam':
/usr/local/src/php-4.3.4/ext/mysql/libmysql/my_tempnam.c:115: the use of 
`tempnam' is dangerous, better use `mkstemp'
/opt/sybase-11.9.2/lib/ undefined reference to `__ctype_b'
/opt/sybase-11.9.2/lib/ undefined reference to `__ctype_tolower'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

After I am done with PHP, I proceed to complete the apache installation.
I used

./configure --prefix=/etc/httpd \

The __ctype error occurred again and abort early in the configure process. I 
searched the both sybase and php sites for this error, I could find quite some 
discussion regarding solving the compilation problem with php, but none 
regarding the same __ctype error ocurring while compiling apache. I would 
highly appreciate if somebody can lend a hand regarding this.

Configuring for Apache, Version 1.3.29
 + using installation path layout: Apache (config.layout)
 + activated php4 module (modules/php4/libphp4.a)
Creating Makefile
Creating Configuration.apaci in src
 + enabling mod_so for DSO support
Creating Makefile in src
 + configured for Linux platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + using "tr [a-z] [A-Z]" to uppercase
 + checking for system header files
 + adding selected modules
    o php4_module uses ConfigStart/End
 + using system Expat
 + using -ldl for vendor DSO support
 + checking sizeof various data types
 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed.  The below error output from the compilation
** test will give you an idea what is failing. Note that
** Apache requires an ANSI C Compiler, such as gcc.

======== Error Output for sanity check ========
cd ..; gcc  -DLINUX=22 `./apaci`     -o helpers/dummy helpers/dummy.c   
-Wl,-rpath,/opt/sybase-11.9.2/lib  -rdynamic 
-L/usr/lib/gcc-lib/i386-redhat-linux/3.2.2 -L/opt/sybase-11.9.2/lib 
-Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmodphp4    -rdynamic 
-L/usr/lib/gcc-lib/i386-redhat-linux/3.2.2 -L/opt/sybase-11.9.2/lib -lcrypt   
-lsybdb -lcrypt -lresolv -lm -ldl -lnsl  -lgcc -lcrypt -lcrypt   -lm -lcrypt 
-lexpat -ldl
/opt/sybase-11.9.2/lib/ undefined reference to `__ctype_b'
/opt/sybase-11.9.2/lib/ undefined reference to `__ctype_tolower'
collect2: ld returned 1 exit status
make: *** [dummy] Error 1
============= End of Error Report =============


The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message