httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bo Boe <boboe...@yahoo.com>
Subject [users@httpd] Vhost configuration problem
Date Tue, 27 Apr 2004 05:08:34 GMT
I am trying to set up a machine with multiple vhosts
running on it all having their own ip address. I tried
the following configuration file, but the virualhost2
does not seem to be working. Could anyone indicate
what I am doing wrong?

I am running apache 2.0.48 on a gentoo linux box.

here is my vhost.conf file:

#Virtualhost 1
NameVirtualHost 192.168.0.5:80

<VirtualHost 192.168.0.5:80>
    Serveradmin webmaster@mydomain.com
    Redirect / https://virtualhost2.mydomain.com
    Servername www.mydomain.com
    Serveralias virtualhost1
    ErrorLog logs/virtualhost1-redirect-error_log
    CustomLog logs/virtualhost1-redirect-access_log
common
</Virtualhost>


#virtualhost 2
NameVirtualHost 192.168.0.6:443

<VirtualHost 192.168.0.6:443>
    Serveradmin webmaster@mydomain.com
    Documentroot /var/www/vhosts/virtualhost2
    Servername virtualhost2.mydomain.com
    Serveralias virtualhost2
    ErrorLog logs/virtualhost2-error_log
    CustomLog logs/virtualhost2-access_log common
    Options Indexes Includes FollowSymLinks
</Virtualhost>


	
		
__________________________________
Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs  
http://hotjobs.sweepstakes.yahoo.com/careermakeover 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message