httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Mindeman <>
Subject [users@httpd] ulimit being ignored
Date Wed, 28 Apr 2004 19:42:51 GMT
I've got kind of a strange problem with Apache 2.0.49 on Solaris 9. 
There are about 160 virtual hosts set up on this server.  When I use the 
rotatelogs program in the CustomLog directive, Apache fails to start up. 
  The error log says that the certificate file for one of the hosts 
cannot be opened because there are too many open files.  When I change 
CustomLog back to logging to a file instead of a process, the server 
starts normally.

I've tried setting the ULIMIT_MAX_FILES variable in apachectl to "ulimit 
-S -n unlimited", but still get the same error.  Its almost as if ulimit 
is being ignored, or isn't getting passed on to the child processes.

Any ideas?
Paul Mindeman
BTInet Systems Administrator

The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message