httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ma, Kenneth K." <...@dmv.ca.gov>
Subject RE: [users@httpd] can't start apache
Date Wed, 28 Apr 2004 19:18:14 GMT
Hello Mr. Campos, I have the Load Module config_log_module
libexec/mod_log_config.so in the httpd.conf.  I did comment this file out to
see what else is wrong.  This is the error message that comes up when I
uncomment this line.

syntax error on line 209 of /usr/local/apache/conf/httpd.conf:
Can't locate API module structure `log_config_module' in file
/usr/local/apache/libexec/mod_log_config.so: ld.so.1:
/usr/local/apache/bin/httpd: fatal: log_config_module: can't find symbol
/usr/local/bin/apache start: httpd could not be started

Thanks for your help.

Kenneth

-----Original Message-----
From: Rodrigo Campos [mailto:rodrigo@geekbunker.org]
Sent: Wednesday, April 28, 2004 12:10 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] can't start apache


Probably you're not loading the config_log_module.

Look for:

LoadModule config_log_module    libexec/mod_log_config.so

and

AddModule mod_log_config.c


In your httpd.conf file.

--
Rodrigo Campos
http://geekbunker.org/rodrigo/?sig
"If you graph the numbers of any system, patterns emerge."
----- Original Message ----- 
From: "Ma, Kenneth K." <kma@dmv.ca.gov>
To: <users@httpd.apache.org>
Sent: Wednesday, April 28, 2004 4:07 PM
Subject: [users@httpd] can't start apache


> Hello, I have compiled apache 1.3.39 and am getting errors related to the
> httpd.conf file.  After recompiling for maximum modules and support for
DSO,
> I am getting the following error message:
>
> apache start
> [Wed Apr 28 08:18:00 2004] [warn] Loaded DSO libexec/mod_jserv.so uses
plain
> Apache 1.3 API, this module might crash under EAPI! (please recompile it
> with -DEAPI)
> Syntax error on line 544 of /usr/local/apache/conf/httpd.conf:
> Invalid command 'LogFormat', perhaps mis-spelled or defined by a module
not
> included in the server configuration
> /usr/local/bin/apache start: httpd could not be started
>
> Any suggestions?  Thanks in advance for your help.
>
> Kenneth
>
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message