httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John P. Dodge" <do...@cruciate.ca.boeing.com>
Subject Re: [users@httpd] ulimit being ignored
Date Wed, 28 Apr 2004 21:12:09 GMT
On Wed, 28 Apr 2004, Paul Mindeman wrote:

>   The error log says that the certificate file for one of the hosts
> cannot be opened because there are too many open files.  When I change
> CustomLog back to logging to a file instead of a process, the server
>
> I've tried setting the ULIMIT_MAX_FILES variable in apachectl to "ulimit
> -S -n unlimited", but still get the same error.  Its almost as if ulimit
> is being ignored, or isn't getting passed on to the child processes.
>
> Any ideas?

What O/S?

If Solaris or HP you probably need to increase the system FD limits.

Solaris:

In /etc/system:

set rlim_fd_max = 4096
set rlim_fd_cur = 2048

Then do s reconfigure re-boot.


HPUX:

Increase MAXNPROC, MAXUPROC, MAXNFILES, (I think).


----------------------------------------
"Mon aƩroglisseur est plein d'anguilles"
John P. Dodge
Boeing Shared Services


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message