httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Hegbloom <hegbl...@pdx.edu>
Subject Re: [users@httpd] SetEnv variables empty for mod_rewrite
Date Wed, 02 Jun 2004 06:13:31 GMT
On Wed, 2004-06-02 at 08:04 +0200, André Malo wrote:
> * "James Taylor" <JTaylor@nextance.com> wrote:
> 
> > I'm trying to set an environment variable from httpd.conf and access it
> > from mod_rewrite statements, but I'm not having any luck.  If I use
> > SetEnvIf instead it works fine.  Below is a sample where I'd expect
> > MyVariable to be set to "foo", but if I examine the rewrite.log file,
> > the variable is always empty.  I must be doing something wrong, because
> > this seems so basic.  Thanks in advance for any help.
> 
> It's  a logical error. SetEnv directives will be evaluated just before the
> handler starts, i.e. way too late for mod_rewrite.

I wonder... if you used mod_perl, and used PerlSetEnv or PerlPassEnv,
wouldn't that be visible to the mod_rewrite?  I'll bet it will be.

-- 
Karl Hegbloom <hegbloom@pdx.edu>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message