httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomasz Chmielewski <man...@interia.pl>
Subject Re: [users@httpd] mod_vscan not working
Date Thu, 01 Jul 2004 08:38:10 GMT
Rajiv Ranjan wrote:
> Hi,
> 
> I am trying to integrate an antivirus (Scanner Deamon) to my apache server
> (It is a proxy to my application server) using mod_vscan.
> 
> Scanner deamon is running on the proxy server at port 8127 and is able to
> detect viruese if I scan files using telent at 8127.
> I did a build and install of mod_vscan and added the following directive to
> my httpd.conf .
> 
> <IfModule mod_vscan.c>
>         SetOutputFilter VSCAN
>         VScanHostname localhost
>         VScanPort 8127
>         VScanErrorDocument /home/rajiv/ScannerDeamon/virusMessage.html
> </IfModule>
> 
> Now whenever I try to download an infected file from the server, I dont get
> any error messages nor is the download interrupted.
> 
> Could any of you who might have done something similar please tell me what is
> it that I might be doing wrong? My apache is running on port 80.

maybe it's not answer to your question, but in my opinion mod_clamav 
would be better for you, as it uses clamav, which is better than 
openantivirus.

mod_clamav is easy to install, let me know if you need help with it.


-- T.




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message