httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Paulsen <rob...@paulsenonline.net>
Subject [users@httpd] Can only access via localhost with SSL
Date Thu, 05 Aug 2004 00:29:02 GMT
Hello,

I am running apache2 (2.0.50) and until today all was well. I made no
changes that I am aware of and suddenly I can no longer access web
pages remotely (using SSL) but only by localhost.

Even on the same machine I can only access via localhost, not by
external IP. I am actually getting to the server since it logs an error. 

Here is a small testcase: I run the following two commands on the server's
own host:

	wget https://localhost
	wget https://192.168.0.31

Here is what gets logged in /var/log/apache2/access_log

	127.0.0.1 - - [04/Aug/2004:19:08:11 -0500] "GET / HTTP/1.0" 200 1456 "-" "Wget/1.9.1"
	192.168.0.31 - - [04/Aug/2004:19:08:17 -0500] "\x80\x8c\x01\x03\x01" 501 987 "-" "-"

And here is the error_log:

	[Wed Aug 04 19:08:17 2004] [error] [client 192.168.0.31] Invalid method in request \x80\x8c\x01\x03\x01

If I turn off SSL and run the following, all is well:

	wget http://localhost
	wget http://192.168.0.31

I tried three different browsers and got the same results.

Should I regenerate my certificates?

-- 
Robert C. Paulsen, Jr.
robert@paulsenonline.net

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message