httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Hilton <jeremy-l...@adtcs.com>
Subject Re: [users@httpd] ssl
Date Tue, 01 Feb 2005 15:05:33 GMT
On 2/1/05 9:56 AM, "Plantier, Spencer" <spencer.plantier@stratech.com>
wrote:

> I recompile apache2.0.52 with enable‹ssl ­ssl path. I try to do ./openssl req
> -new -out server.csr and and get the following error. I have libssl.s0.0.9.7
> in my env (/usr/local/ssl/lib)
> 
> cd /usr/local/ssl/bin
> 
> # ls -l
> 
> total 936
> 
> -rwxr-xr-x   1 root     bin         3654 Oct 29 05:11 c_rehash
> 
> -rwxr-xr-x   1 root     bin       463196 Oct 29 05:11 openssl
> 
> # ./openssl req -new -out server.csr
> 
> ld.so.1: ./openssl: fatal: libssl.so.0.9.7: open failed: No such file or
> directory
> 
> Killed
> 
> # env
> 
> HOME=/
> 
> HZ=100
> 
> LD_LIBRARY_PATH=/opt/sfw/gcc-3/lib:
> 
> LOGNAME=root
> 
> PATH=/opt/sfw/gcc-3/bin:/usr/ccs/bin:/home/splantier/openssl:/usr/local/ssl/li
> b:/usr/sbin:/usr/bin
> 
> SHELL=/sbin/sh
> 
> TERM=vt100
> 
> TZ=US/Eastern
> 
> #
> 
> Any help would be appreciated.
> 
> Spencer Plantier
> 
> System Network Administrator
> 
>  
> 
> 301 Gregson Dr
> 
> Cary, NC  27511
> 
> Office 919-379-8513
> 
> Cell    919-272-8833
> 
> spencer.plantier@stratech.com
> 
> 

Not really an apache issue.... But try prepending strace to your command. It
should tell you where openssl is looking for that lib file. You might have
to put that path in /etc/ld.so.conf and then run ldconfig.


Jeremy
  

Mime
View raw message