httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Zagarello <bz...@yahoo.com>
Subject Re: [users@httpd] Apache install
Date Fri, 08 Apr 2005 18:18:29 GMT

Do you need to put a LoadModule directive in
httpd.conf for ssl?  Do a search in your httpd.conf
for "DSO".  Check if your mod_ssl was statically
compiled using "httpd -l" which lists the statically
compiled modules.

BZAG
+++++++++++++++++++++++

>From Spencer Plantier:

I have installed openssl without any errors and php
without any errors. Could someone help me troubleshoot
this error. I am new to apache and am starting to hit
deadlines on trying to get apache up and running. Any
help would be greatly appreciated. 

This is how I built openssl:

../config
make
make build-shared
mv libssl.so* /usr/local/lib
mv libcrypto.so* /usr/local/lib


Syntax error on line 251 of
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/mod_ssl.so into
server: ld.so.1:
/usr/local/apache2/bin/httpd: fatal: relocation error:
file
/usr/local/apache2/modules/mod_ssl.so: symbol
X509_INFO_free: 
referenced
symbol not found
# 










++++++++++++++++++++++++++++++
"Oh fools, so hard do ye tread the mines lain at Golgotha in search of reality for the sake
of truth, only to find it and despair !  Yes, Death is reality and true, but it need not be
your calling !"
-  The Christologic Clown.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message