httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Schreiner <schre...@bc.edu>
Subject Re: [users@httpd] Runaway thread, troubleshooting tools needed
Date Wed, 13 Apr 2005 20:15:44 GMT

On Apr 13, 2005, at 4:11 PM, Ivan Barrera A. wrote:

> Ivan Barrera A. wrote:
>>>
>>> I don't have an answer for you, but am experiencing the same problem 
>>> with 2.0.53 compiled and running on OS X server. It was also 
>>> happening with 2.0.52. Mine was also built with MPM=worker
>>>
>>> I have attached gdb to the runaway process, and get this backtrace 
>>> (every time the same)
>>>
>>> #0  0x9000eac4 in read ()
>>> #1  0x00011030 in ap_mpm_pod_check ()
>>> #2  0x0000ecc8 in child_main ()
>>> #3  0x0000eee8 in make_child ()
>>> #4  0x0000f52c in perform_idle_server_maintenance ()
>>> #5  0x0000f838 in server_main_loop ()
>>> #6  0x0000fc90 in ap_mpm_run ()
>>> #7  0x00012df0 in main ()
>>> #8  0x000029f8 in _start ()
>>> #9  0x0000286c in start ()
>>>
>>> but, I'm at a loss of what to investigate next.
>>>
>>> Tony
>> You need to be sure , you're using mods or functions that are not 
>> thread-safe...
>
>
> ehm.. i mean "you're not using mods..."
>
>

If I am, is there another option for building.
Tony


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message