httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig Dunigan <cduni...@doit.wisc.edu>
Subject RE: [users@httpd] Win32 Apache Restart
Date Wed, 04 May 2005 15:38:04 GMT
Now I'm going to reverse myself.  If the vendor says mod_jk2, I'd use 
mod_jk2, deprecated or not.  Vendors often have weird license requirements 
that invalidate your support and/or warranty if you don't follow their 
directions _exactly_, including using buggy software if that's what they 
want.  Sorry for the wild goose chase.

Craig

On Wed, 4 May 2005 lherbst@propappr.marion.fl.us wrote:

> Okay.  Does anyone have ArcIMS 9 working with mod_jk?  ESRI's installation
> instructions specify mod_jk2.
> 
> If not, I'm going to attempt to move to mod_jk myself and see if it works.
> 
> Lee
> 
> 
> 
> 
>                                                                            
> 
> I'd like to note that mod_jk2 is deprecated.  From
> http://jakarta.apache.org/tomcat/connectors-doc/news/20041100.html:
> 
>   15 November [2004] - JK2 is officially unsupported
> 
>   JK2 has been put in maintainer mode and no further development will take
>   place. The reason for shutting down JK2 development was the lack of
>   developers interest. Other reason was lack of users interest in adopting
>   JK2, caused by configuration complexity when compared to JK.
> 
> I can't say much from experience, just hearsay, but I recall reading that
> another reason was mod_jk2 was buggy....
> 
> --
> Craig Dunigan
> 
> On Wed, 4 May
> 2005 lherbst@propappr.marion.fl.us wrote: > >
> >
> >
> > Yes, I'm using mod_jk and I have found some errors in my log associated
> > with that mod.  Most did not occur at the same time as my restart
> problem,
> > although the ones quoted below occured about a minute and a half prior to
> > the restart.   Did some research on Google on the errors, but cannot find
> > any definitive answer to what caused it, just that it is associated with
> > Tomcat.  Below are the errors I found:
> >
> > [Mon May 02 10:55:14 2005] [error] jk2_channel_apr_send send failed
> 730053
> > An established connection was aborted by the software in your host
> machine.
> > [Mon May 02 10:55:14 2005] [error] ajp13.service() Error sending initial
> > post -3 0 0
> >
> >
> > Has anyone seen these before or know what they mean?
> >
> > Lee
> >
> >
> >
> >
> >
> > I have the same Problem on Win 2000 Server with
> >
> > Server Version: Apache/2.0.53 (Win32) DAV/2 mod_ssl/2.0.53 OpenSSL/0.9.7d
> > mod_jk/1.2.8
> >
> > I saw this in past some times at day. Current I have no entries
> > in log, where I'm sure that the restart wasn't I.
> >
> > What I see is, that Lee also use mod_jk.
> >
> > regards Dietmar
> >
> 
> 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message