httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <>
Subject Re: [users@httpd] Apache 1.3 not honoring +ExecCGI or +FollowSymLinks in UserDir on OS X Tiger
Date Thu, 23 Jun 2005 16:01:22 GMT
On 6/23/05, Carl Youngblood <> wrote:
> I'm having trouble trying to execute CGIs and follow symlinks under
> user web shares (~user style directories) on Mac OS X Tiger.
> I've changed httpd.conf so that the / and DocumentRoot directories
> both have AllowOverride Options. I've turned web sharing on. I've set
> the user dir (/Users/*/Sites) to Options +ExecCGI +FollowSymLinks, and
> yet I get a forbidden message every time I try to either follow a
> symlink or execute a cgi script. Here is what I get in the Apache
> error log:
> [Wed Jun 22 21:11:28 2005] [error] [client] Options ExecCGI
> is off in this directory: /Users/carl/Sites/test.cgi
> [Wed Jun 22 21:11:41 2005] [error] [client] Symbolic link
> not allowed: /Users/carl/Sites/symlink/
> If I try to do these things in the DocumentRoot
> (/Library/Webserver/Documents), it works just fine. It's almost as if
> mod_userdir is ignoring my options directives. I've tried specifying
> the directives both inside httpd.conf and in an .htaccess file and
> neither seems to work.

For symlinks to work, the FollowSymLinks option must be present for
the directory containing the symlink, not the target directory.  Are
you sure you have done that?  Have you tried allowing symlinks from
the root?


The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message