httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Ray [Lists]" <li...@blazestudios.com>
Subject [users@httpd] Apache 2.0 and OpenSSL
Date Wed, 20 Jul 2005 20:53:02 GMT
I'm running apache 2.0 on a suse 9.1 box and I'm trying to get openSSL 
to run with it. Now when I do a ps -ef I see that SSL is running with apache

wwwrun   24131  2115  4 16:45 ?        00:00:15 /usr/sbin/httpd2-prefork 
-f /etc/apache2/httpd.conf -Dssl
wwwrun   24157  2115  3 16:45 ?        00:00:13 /usr/sbin/httpd2-prefork 
-f /etc/apache2/httpd.conf -Dssl
wwwrun   24836  2115  9 16:50 ?        00:00:06 /usr/sbin/httpd2-prefork 
-f /etc/apache2/httpd.conf -Dssl

But whenI try to connect with ssl I run into problems. I've tried 
trouble shooting from the server command line but I don't understand the 
errors I'm getting, if someone can help or point me in the right spot 
that would be great!

What I'm doing and the response:

srvr1:~ # openssl s_client -connect 64.59.95.68:443
CONNECTED(00000003)
27014:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown 
protocol:s23_clnt.c:475:

Thanks!

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message