httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Barrera A." <Br...@Ivn.cl>
Subject Re: [users@httpd] Aliased interface -- bind failed, address in use
Date Wed, 03 Aug 2005 19:48:10 GMT

Kevin DeGraaf wrote:
> I have a Linux 2.4.27 machine with the following interface configuration:
> 
> eth0   [xx.xx.xx.162] UP BROADCAST RUNNING etc.
> eth0:1 [xx.xx.xx.165] UP BROADCAST RUNNING etc.
> 
> I can ping the machine on both interfaces.
> 
> I have OpenVPN running on tcp/xx.xx.xx.165:443 and nothing running on
> tcp/xx.xx.xx.162:443, as demonstrated:
> 
> # netstat -pan -Ainet | grep 443
> tcp 0 0 xx.xx.xx.165:443 yy.yy.yy.yy:57928 ESTABLISHED 6517/openvpn

That doesn't demonstrate that OpenVPN is only "listening" on the 165
interface.
netstat -nlp | grep 443
should.

> 
> My Apache 1.3.33 configuration contains "Listen xx.xx.xx.162:443".  All
> "BindAddress" and "Port" statements are commented out.
> 
> Upon attempted startup, I receive the following log message:
> 
> [crit] (98)Address already in use: make_sock: could not bind to address
> xx.xx.xx.162 port 443
> 
> Ideas?
> 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message