httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Wilson <>
Subject [users@httpd] mod_userdir and FollowSymLinks frustration
Date Thu, 04 Aug 2005 21:59:41 GMT
I am having trouble getting my user's web directories to behave the 
FollowSymLinks option. I know I must be making a stupid mistake here but 
I have spent way too much time trying to track down the problem.

I'm using Apache 2.0.54 on Gentoo, and have taken the issue down a very 
basic config which illustrates the problem:

# cat /etc/apache2/httpd.conf
User apache
Group apache
Listen 80
PidFile "/var/run/"
LogLevel Debug
ErrorLog /var/log/apache2/test.log
LoadModule userdir_module modules/
LoadModule dir_module modules/
DirectoryIndex index.html
<Directory /home/avarice/public_html>
         Options Indexes FollowSymLinks

# ls -l /home/avarice/public_html/
-rw-r--r--  1 avarice users   12 Jun 18  2001 index.html
lrwxrwxrwx  1 root    root    31 Aug  4 15:22 richhorner -> 

# ls -ld /var/www/
drwxr-xr-x  13 avarice users 624 Aug  3 14:27 

Now, when I visit http://myserver/~avarice I get the (unparsed) contents 
of index.html, as expected. If I remove the "Indexes" option from my 
config I no longer get the index.html file contents by default, again as 
expected (just to make sure that Options line was getting used).

However, when I try to access http://myserver/~avarice/richhorner I get 
an access denied error:

# cat /var/log/apache2/test.log
[Thu Aug 04 15:39:03 2005] [notice] caught SIGTERM, shutting down
[Thu Aug 04 15:39:04 2005] [notice] Apache/2.0.54 (Gentoo/Linux) 
configured -- resuming normal operations
[Thu Aug 04 15:39:04 2005] [info] Server built: Jul 27 2005 16:28:52
[Thu Aug 04 15:39:04 2005] [debug] prefork.c(956): AcceptMutex: sysvsem 
(default: sysvsem)
[Thu Aug 04 15:39:07 2005] [error] [client] Symbolic link 
not allowed: /home/avarice/public_html/richhorner

I have tried and tried, but cannot get this to work. I successfully use 
FollowSymLinks and SymLinksIfOwnerMatch elsewhere in my full 
configuration, but when it comes to mod_userdir I'm having trouble.


The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message