httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Blondel" <>
Subject [users@httpd] apache Read/Write permissions problems ???
Date Mon, 03 Oct 2005 13:00:37 GMT

Hello all,

My society needs a package containing apache that must meet next requirements :

- all data , software and configuration must be isolated in /opt/apache
- the package needs to run on FreeBSD
- /opt/apache ( and all files in it ) must be owned by user:group apache:apache <-->
- httpd must run as user:group www:apache

The advantage of such a configuration is that

- we can easily update our software on all of our servers
- we can give the System Administration to this branch of our IT services to a dedicated team
without giving them the root password
- httpd process can run safely with only write access on the directories where it is absolutely
needed ( log, run , ... )


The package is now ready but I get some problems. When I run apachectl as root user, process
httpd runs correctly but when I run it as
user apache , I get next error :

[emerg] (2)No such file or directory: Couldn't create accept lock

The problem is I don't know what file cannot be read ?


The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message