httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hulya Gurer <hulya.gu...@varianinc.com>
Subject Re: [users@httpd] .htaccess problem
Date Tue, 06 Dec 2005 22:27:57 GMT

My DocumentRoot is /varian/docs.  The .htaccess files are on 
/varian/docs/mars/  and
/varian/docs/addm/ directories.   When I try to get 
http://test.varianinc.com/index.html  the password window pops up
even this is not the password protected directory just a home page, and 
also I get different
behavior each time.  For example, I tried to close the password window by 
clicking on "x" several times,
and it served the page without .css, and tried the second time with 
"Cancel" and "x" and I got message
that I should get, which said (I think) "Authorization Failure".  At that 
point the error log reads
[Tue Dec 06 13:31:45 2005] [error] [client 4.22.71.52] user  not found: 
/mars/

ERROR LOGS

[Tue Dec 06 09:53:50 2005] [error] [client 4.22.71.52] user  not found: 
/mars/themes/varian/header_background.
jpg, referer: http://viking.varianinc.com/
[Tue Dec 06 09:54:03 2005] [error] [client 4.22.71.52] user  not found: 
/mars/xoops.css, referer: http://vikin
g.varianinc.com/index.html
[Tue Dec 06 09:56:19 2005] [notice] caught SIGTERM, shutting down
[Tue Dec 06 09:56:27 2005] [notice] Apache/2.0.55 (Unix) DAV/2 PHP/5.0.5 
configured -- resuming normal operati
ons
[Tue Dec 06 09:57:23 2005] [error] [client 4.22.71.52] user  not found: 
/mars/xoops.css, referer: http://vikin
g.varianinc.com/

[Tue Dec 06 13:31:22 2005] [error] [client 4.22.71.52] user  not found: 
/mars/include/xoops.js, referer: http://test.varianinc.com/index.html
[Tue Dec 06 13:31:23 2005] [error] [client 4.22.71.52] user  not found: 
/mars/themes/varian/header_background.jpg, referer: 
http://test.varianinc.com/index.html


ACCESS LOGS

4.22.71.52 - - [06/Dec/2005:13:28:31 -0800] "GET / HTTP/1.0" 200 8900 "-" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
4.22.71.52 - - [06/Dec/2005:13:28:31 -0800] "GET /mars/xoops.css HTTP/1.0" 
401 501 "http://test.varianinc.com/" "Mozilla/4.0 (compatible; MSIE 6.0; 
Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:28:43 -0800] "GET /mars/xoops.css 
HTTP/1.0" 304 - "http://test.varianinc.com/" "Mozilla/4.0 (compatible; MSIE 
6.0; Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:28:43 -0800] "GET 
/mars/themes/varian/styleNN.css HTTP/1.0" 304 - 
"http://test.varianinc.com/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 
5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:28:43 -0800] "GET 
/mars/themes/varian/style.css HTTP/1.0" 304 - "http://test.varianinc.com/" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:28:43 -0800] "GET 
/mars/script/breadcrumb_menu.js HTTP/1.0" 304 - 
"http://test.varianinc.com/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 
5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:28:43 -0800] "GET 
/mars/include/xoops.js HTTP/1.0" 304 - "http://test.varianinc.com/" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:28:43 -0800] "GET 
/mars/themes/varian/header_background.jpg HTTP/1.0" 304 - 
"http://test.varianinc.com/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 
5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:28:43 -0800] "GET 
/mars/themes/varian/hbar.gif HTTP/1.0" 304 - "http://test.varianinc.com/" 
"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
4.22.71.52 - "" [06/Dec/2005:13:32:44 -0800] "GET /mars/ HTTP/1.0" 401 501 
"-" "Mozilla/4.0 (com
patible; MSIE 6.0; Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:32:54 -0800] "GET /mars/ HTTP/1.0" 302 
- "-" "Mozilla/4.0 (c
ompatible; MSIE 6.0; Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:32:55 -0800] "GET /mars/xoops.css 
HTTP/1.0" 304 - "http://vi
king.varianinc.com/mars/modules/vikingcontent/" "Mozilla/4.0 (compatible; 
MSIE 6.0; Windows NT 5
.0)"
4.22.71.52 - marvin [06/Dec/2005:13:32:55 -0800] "GET 
/mars/themes/varian/style.css HTTP/1.0" 30
4 - "http://test.varianinc.com/mars/modules/vikingcontent/" "Mozilla/4.0 
(compatible; MSIE 6.0
; Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:32:54 -0800] "GET 
/mars/modules/vikingcontent/ HTTP/1.0" 200
  24611 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)"
4.22.71.52 - marvin [06/Dec/2005:13:32:55 -0800] "GET 
/mars/script/breadcrumb_menu.js HTTP/1.0"
304 - "http://test.varianinc.com/mars/modules/vikingcontent/" "Mozilla/4.0 
(compatible; MSIE 6
.0; Windows NT 5.0)"








> > Hello,
> >
> > I have apache 2.0.55 running on solaris 8, along with PHP and mysql.  For
> > some reason I am getting strange responses
> > from .htaccess.
> >
> > First of all, my .htaccess file is on the second level subdirectory but for
> > some reason, I get the password window
> > at home page, and when I click on cancel two, three times, it shows the
> > page without the header which is SSI.
> > My home page is "index.html" and sub directory pages are being served 
> from php.
> >
> > My configuration for .htaccess is like below, which is set to
> > "AuthConfig"  Is there anything else that needs to be added / changed?
> > Is there any specific setting for serving php controlled pages?
>
>Give us some more concrete information about exactly where your
>.htaccess file, DocumentRoot, etc are, and exactly what you see in the
>access_log and error_log.
>
>Joshua.
>
>---------------------------------------------------------------------
>The official User-To-User support forum of the Apache HTTP Server Project.
>See <URL:http://httpd.apache.org/userslist.html> for more info.
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message