httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Unterkircher <>
Subject [users@httpd] shared object build problem
Date Sat, 15 Apr 2006 07:19:01 GMT
Hello list,

What can be wrong when during my build of Apache 2.0.5x (also tried with 
2.2.0) I'm missing some shared objects files.
My system is Debian SID (also have the same issue with an SuSE Linux 
Enterprise Server 9), gcc 4.0.3, libtool 1.5.22,
ld 2.16.91,...

Background of this problem is, that I'm not able to build any loadable 
module (mod_ntlm, mod_python, mod_perl) for
my Apache. They only module that can be built is mod_php4 & mod_php5. 
But every other piece of software on these
servers (subversion, mysql 5.0,... ) is able to build its shared object 

However I think I traced down it, that during the build of Apache there 
is some problem because there are no shared
objects in the lib directory.

root@server1:~# ls -l /usr/local/apache2/lib/
-rw-r--r-- 1 root staff   7891 Apr 15 07:57 apr.exp
-rw-r--r-- 1 root staff   3692 Apr 15 07:57 aprutil.exp
-rw-r--r-- 1 root staff 651240 Apr 15 07:57 libapr-0.a
-rw-r--r-- 1 root staff    805 Apr 15 07:57
-rw-r--r-- 1 root staff 437356 Apr 15 07:57 libaprutil-0.a
-rw-r--r-- 1 root staff    779 Apr 15 07:57

But neither make or make install shows any error or warning message. 
Also I tried (like suggested in some posts I found)
to run buildconf which successfully generated configure and all the 
other things which should avoid some issues with older
libtool version. But also then - afters a recompile - I still miss the 
.so files.

Anyone has a clue what can cause this?


The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message